Cannot get pyblish_qml running got error AttributeError: 'module' object has no attribute 'pyqtWrapperType'


#1

Perhaps this could be a silly post but after some tries i gave up on getting pyblish_qml running so i need help from some charitable soul on this. I just want to mention I’m currently using windows and python 2.7 version.

I’d like to go step by step:

1 - I’ve installed pyblish from from windows console (this also brings pyblish_qml package)
C:\Python27\Scripts>pip install pyblish

2 - Then i’ve installed pyqt5 this way.
C:\Python27\Scripts>pip install git+git://github.com/pyqt/python-qt5.git
and tested the installation like mentioned on https://github.com/pyqt/python-qt5 successfully

3 - Set these env vars:
set PYBLISH_QML_PYTHON_EXECUTABLE=c:\python27\python.exe
set PYBLISH_QML_PYQT5=C:\Python27\Lib\site-packages\PyQt5

4 - Tried again just in case pyblish_qml installation
pip install pyblish-qml

and i got as a result:
Requirement already satisfied: pyblish-qml in c:\python27\lib\site-packages (0.7.0)
Requirement already satisfied: pyblish-base>=1.4 in c:\python27\lib\site-packages (from pyblish-qml) (1.4.3)

so go ahead with the “Test out the installation with”
python -m pyblish_qml --demo

and this ends up on this error:

C:\Python27>python -m pyblish_qml --demo
Traceback (most recent call last):
File “C:\Python27\lib\runpy.py”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “C:\Python27\lib\runpy.py”, line 72, in run_code
exec code in run_globals
File "C:\Python27\lib\site-packages\pyblish_qml_main
.py", line 6, in
from . import app
File “C:\Python27\lib\site-packages\pyblish_qml\app.py”, line 13, in
from . import util, compat, server, control, rpc, settings
File “C:\Python27\lib\site-packages\pyblish_qml\control.py”, line 11, in
from . import util, models, version, settings, rpc
File “C:\Python27\lib\site-packages\pyblish_qml\models.py”, line 94, in
class PropertyType(QtCore.pyqtWrapperType):
AttributeError: ‘module’ object has no attribute ‘pyqtWrapperType’

What am i missing?
Can somebody give me a hand on this?
Thanks in advance


#2

Hi @ramirotell,

Thanks for reporting this. It looks like a mismatch between Pyblish QML and the version of PyQt5.

I noticed you’ve got 1.4, which is quite old. Could you try a later version?

$ pip install pyblish-qml --upgrade
$ python -m pyblish_qml --demo

#3

Hi Marcus and thanks once more!.
Just a silly question, how do i update pyqt5 version?

All pyblish installations and also pyqt5 following github instructions were done yesterday, so those versions (pyblish packages) were from running:
pip install pyblish

For installing Pyqt5 i also followed github instructions:
pip install git+git://github.com/pyqt/python-qt5.git

Do i have also to update pyqt5?, is there any comand to update it from pip install?

Besides that i run what you said on your response
pip install pyblish-qml --upgrade

And it seems to succeeded but also print this out:

C:\Python27\Scripts>pip install pyblish-qml --upgrade
Collecting pyblish-qml
** Downloading https://files.pythonhosted.org/packages/d6/00/7e3ffdb8c54438c096959ea894fdaedee9c0cc24fc2334cca92c1d103181/pyblish-qml-1.7.4.tar.gz (1.4MB)**
** 100% |UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU| 1.4MB 1.3MB/s**
Collecting pyblish-base==1.5.3 (from pyblish-qml)
** Downloading https://files.pythonhosted.org/packages/90/fd/8ab84507d535c8000cb7b1e8bfd186a3372d07b348bf9bf32c192de039ee/pyblish-base-1.5.3.tar.gz (117kB)**
** 100% |UUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUU| 122kB 1.7MB/s**
pyblish 1.4.3 has requirement pyblish-base==1.4.3, but you’ll have pyblish-base 1.5.3 which is incompatible.
pyblish 1.4.3 has requirement pyblish-qml==0.7.0, but you’ll have pyblish-qml 1.7.4 which is incompatible.
Installing collected packages: pyblish-base, pyblish-qml
** Found existing installation: pyblish-base 1.4.3**
** Uninstalling pyblish-base-1.4.3:**
** Successfully uninstalled pyblish-base-1.4.3**
** Running setup.py install for pyblish-base … done**
** Found existing installation: pyblish-qml 0.7.0**
** Uninstalling pyblish-qml-0.7.0:**
** Successfully uninstalled pyblish-qml-0.7.0**
** Running setup.py install for pyblish-qml … done**
Successfully installed pyblish-base-1.5.3 pyblish-qml-1.7.4

But now qml_demo runs!
Marcus, just wanted to thank you for your help, really!
Best,


#4

Happy to hear it works!

To my knowledge, there is no newer version of PyQt5 available for Pytnon 2.7 aside from building one for yourself. However, if you wanted to use a later version, Pyblish QML also runs with Python 3.4+ (which also works with the same set of hosts, like all versions of Maya and Nuke and Houdini etc. etc.). And Python 3 has PyQt5 available via pip.

$ python3 -m pip install PyQt5=5.7.1

However, the very latest versions of PyQt5 aren’t compatible with Pyblish QML, so best to stick with 5.9 or below.


#5

You did a really amazing job
Nice to be able to test this qml ui
Thank you marcus!