Pyblish-qml PyQt5 problem


I have two scenarios. I tried building PyQt5 for Maya 2019 via these instructions

It built fine, and I have access to it. However, trying to get pyblish_qml to recognize it is a different story. The latter link’s result is a PyQt5 build in …\Maya2019\Python\Lib\site-packages

from pyblish_qml import api, show

# Tell QML about dependencies
api.register_pyqt5("C:\Program Files\Autodesk\Maya2019\Python\Lib\site-packages")


But I’m faced with this problem: This application failed to start because it could not find or load the Qt platform plugin "windows". This message is a lot like when there is something wrong with your Maya2019\bin\qt.conf file.

To circumvent this I tried install python-qt5 with pip as the full git clone takes too long on my stone age internet connection, so it’s PyQt5.3

Trying to show pyblish_qml gets me a blank grey window but I’m then stuck with a new error:
../pyblish-qml/pyblish_qml/qml/app.qml:9:1: module "QtQuick.Controls" version 1.3 is not installed

Any one have any idea how I can get this working?

You shouldn’t mix Maya’s site-packages with your system c:\python27, they are compiled using different versions of Visual Studio (2008 versus 2015, if I remember correctly) and may cause hard-to-debug errors related to that.

Try this.

c:\python27\python -m pip install git+git://

And then from within Maya.

from pyblish_qml import api, show

# Tell QML about dependencies
# api.register_pyqt5(r"C:\python27\lib\site-packages")


QML will find PyQt5 via python27, but if you wanted you could uncomment that second line as well. Bottom line is that Maya doesn’t need PyQt5 for pyblish-qml to work. Only pyblish-qml does. pyblish-qml doesn’t need Maya either, only pyblish-base. Long story, but it helps to think of pyblish-qml as not written in Python, but in another language, like Go or C++. It’s completely independent of Maya and Maya’s Python.

Ps: your second path previously had backslashes in it, but was not a “raw” string, which turn backslash followed by character into a different character, such as \n for newline.

Ha, yes I did see. Sorry. I’m really not as incompetent as I appear :sweat_smile: But your code handled it well regardless :+1:

I understand that. I came upon the idea of building the latest version of PyQt5 for maya from another forum post where the person was also struggling with the pylish_qml part. My PYTHONPATH does not contain that location. I only tried using it in the api.register_pyqt5 method.

Before I did try using pip to get python-qt5 into python27’s site packages. But that is when I got the error (it’s not the latest version if I understand your git readme correctly). Perhaps downloading the latest one via c:\python27\python -m pip install git+git:// will do the trick then.

@marcus I can confirm that pip install python-qt5 did not work for me but pip install git+git:// worked well. That was the problem all along. Thanks for your help.

1 Like