[solved] Publish from two hosts simultanously


#1

I’ve noticed some issues with having two hosts open, like two sessions of Maya, where pyblish-qml opens but there is nothing in the dialog. Even the terminal is completely empty.

Anyone else experienced the same?


#2

Hm, haven’t seen that before.

What happens when you refresh Pyblish in the other Maya?


#3

Not the exact same issue, but its similar.

  • open one task; modeling
  • publish the scene and keep the session open
  • open task; rigging
  • publish
  • pyblish-qml has the completed session from the modeling task, and I can’t reset.
  • resetting in the modeling session, resets in the rigging session but the instances from the modeling session is in the rigging session. Also can’t publish from the rigging session.

#4

You can enable the QML console which might give you some hints.

  1. Start by quitting the GUI, by holding shift when closing the window.
  2. Then run this.
# Enable console
import os
os.environ["PYBLISH_QML_CONSOLE"] = "1"

# Show GUI
import pyblish_maya
pyblish_maya.show()

#5

This sounds like a bug.

In general, prefer closing the GUI when you’re done. I’ll have a look at tightening up what happens when the GUI remains open.


#6

In general, prefer closing the GUI when you’re done. I’ll have a look at tightening up what happens when the GUI remains open.

The GUI was closed in the modelling task, but still got the bug.


#7

Ah, thanks for that.

How are you working around it currently?


#8

Open one task at a time:) No multi-tasking here.


#9

Haha, aw. :slight_smile: That’s no good.

If you try opening the console, you might be told about an error. If you could post that here, that would help a lot.


#10

Don’t get a console with the code above.


#11

Are you sure you held Shift while closing the GUI, before running that?


#12

Sorry, didn’t look at it. Tried doing this without opening two tasks, and got;

# Error: error: file C:\Program Files\Autodesk\Maya2015\bin\python27.zip\socket.py line 571: 10061 #

Also no UI.


#13

That’s ok, it happens because Shift-quitting if a way of forcefully quitting Pyblish QML, it doesn’t let Maya finish off the connection. If you try starting the GUI again, it should work a bit better.


#14

Still not getting any UI.


#15

Ok, another way to get the terminal, is to set the variable before launching Maya. That way, we won’t have to deal with Shift-closing.


#16

success:)


#17

Bingo!

Ok, interesting, it looks like it has to do with Pyblish QML switching between hosts. I haven’t encountered it before, but should be able to find a solution for it. Thanks for investigating!


#18

Was there a solution for this?


#19

I can’t replicate the problem here, so I’m not sure how to solve it.

Have you tried hosting Pyblish locally, and running multiple hosts? That would tell me whether the problem is related to network hosting or not.


#20

Tried a local running Pyblish, and still getting the problems:(